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This document provides step-by-step instructions designed to get you up and running quickly with 
CADWorx Plant and the new features. The individual lessons that make up this tutorial provide 
hands-on practice using the new features in CADWorx Plant. 

We welcome comments or suggestions about this documentation. You can send us an email at: 
PPMdoc@intergraph.com. 

Intergraph® gives you permission to print as many copies of this document that you need for 
non-commercial use at your company. You cannot print this document for resale or redistribution 
outside your company. 
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S E C T I O N  1  

A solid working knowledge of AutoCAD is required to complete the lessons in this tutorial. 
AutoCAD is delivered with a comprehensive online Help library. To access this library, press F1 
while a menu item is highlighted. If the AutoCAD setvar TOOLTIPS is set to 1, CADWorx Plant 
displays a descriptive tooltip about the command when you rest the mouse pointer on top of a 
command icon. 

 

The lessons in this tutorial make extensive use of toolbars and commands that are available only 
on the AutoCAD Plant menu. Consequently, you must have AutoCAD menus on while you are 
working a tutorial lesson. To turn on AutoCAD menus, type MENUBAR on the command line, and 
then type 1. The AutoCAD menu bar is outlined in red in the figure below. 
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The quickest way to access CADWorx Plant toolbars is to click Plant > Toolbars, and then select 
a toolbar in the list. The toolbars displays in the drawing environment, where it remains until it is 
removed.  

 

You can also dock toolbars anywhere you prefer. For information on docking toolbars, refer to the 
AutoCAD documentation.  

All references to a menu command are accompanied by a reference to the AutoCAD command 
line entry. These commands are just for reference. Aliases for all these commands are listed in the 
[Product Folder]\Support\Pipe_alt.pgp file. For more information about command aliases, see 
Aliases and Command Names in the CADWorx Plant User's Guide. Additionally, if a command 
can be accessed using one of the CADWorx Plant-specific panels instructions for doing so are 
also included. 

A set of sample drawing files, for both English and metric units, accompanies each lesson. 
Optionally, you can use the tutorial drawing file that corresponds to the lesson, or you can save 
your drawing when you complete a lesson so that it can be used in the next lesson. If you intend to 
use the tutorial drawing files, we recommend that you make a backup copy of the sample files so 
that they can be used multiple times within different sections of the tutorial. 

  

 Tutorial lessons can be completed using metric or English units. References to English units 
that appear in a lesson are immediately followed by their metric counterparts in parenthesis, 
such as 4" (102mm). 

 Throughout this tutorial, it is assumed that the working folder is [Product Folder]\Tutorial. If you 
work CAESAR II and CADWorx data transfer (on page 41), we recommend that you use the 
[Product Folder]\Tutorial folder as well. 
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Set drawing parameters 
Each time you begin a new drawing you must use the CADWorx Plant Setup dialog box to define 
drawing parameters as required for the current project. For more information about setup options, 
see Setup Size/Spec Panel in the CADWorx Plant User's Guide. 

1. Click Setup  on the Settings toolbar. Alternatively, type SETUP on the command line, and 
then press ENTER. 

 You can also click the CADWorx Plant I tab, and then click Setup  on the Setup 
Size/Spec panel. 

The CADWorx Plant Setup dialog box displays.  

2. Select 3D Solids in the Drawing Mode list. 

3. Select Socket in Fitting Mode list. 

4. You can change the colors of the Compass, the Dimension, or the Highlight. The default 
color is red. For more information on the compass, see Compass in the CADWorx Plant 
User's Guide. 

5. Select Configuration Settings. 

The Configuration Settings list displays.  

6. Under Configuration Settings, make sure SystemMeasure is set to English/Inch 
(Metric/Metric). For more information, see Configuration Settings, and Startup Variables in the 
CADWorx Plant User's Guide.   

7. Select Specification / Size.  

The Set Specification and Size dialog box displays.   

 This dialog box can also be found by clicking Main Size  on the CADWorx Plant I tab 
on the Setup Size/Spec panel. This is the same dialog box except that the name of the dialog 
box does not appear in the CADWorx Plant Setup dialog box. 

8. Click Browse, and then navigate to the CADWorx Spec folder. 

9. Select Sample_Inch.prj (Sample_Metric.prj) in the list of available project specs, and then 
click Open. 

The specifications display in the Specifications box. 

10. Select 150 (150_mm). 

The sizes display in the Main / Reduction size box. 

11. Select 4" (100) under M for the main and then 2" (50) under R for the reduction. 

A check-mark appears next to each selected size. 

12. Select Configuration Layers. 

The layers list displays. 

 These are the colors and linetypes for the components. 

13. Leave the layers as they are. 

14. Select Piping Rules.  

The Piping Rules list displays. 

15. Select Apply Weld Insertion Rule, and then change the list to Automatic - Buttweld and 
Socket Weld. 

16. Select Apply Gasket Insertion Rule, and then change the list to Automatic. 

17. Select Apply Bolt Insertion Rule, and then change the list to Automatic. 
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18. Click Apply & Close on the CADWorx Plant Setup dialog box. 

19. Click File > Save As. 

20. Type Plant1 in the File name box, and then click Save. 

By default, the file is saved in AutoCAD 2010 Drawing (*.dwg) format. 

 

 To modify nominal size data, click Main Size  on the Settings toolbar.  

 To modify the assigned specification, click Specification  on the Settings toolbar.  

 You can also access Main Size  on the Setup Size/Spec panel when the CADWorx Plant 
I tab is selected. 

 

Route Modeling 
1. Do one of the following: 

 Open the Plant1.dwg drawing file that you saved in Set drawing parameters (on page 9). 

 Open the [Product Folder]\Plant\Tutorial\Tutor1.dwg file delivered with the software.  

 To create a drawing based on metric units, open the [Product 
Folder]\Plant\Tutorial\Tutor1m.dwg file. 

2. Click the View tab, and then select SW Isometric  in the Views palette.    

3. Click the CADWorx Plant I tab, and then click Auto Route  on the RT panel. Alternatively, 
type AUTOROUTE or ROUTE on the command line, and then press ENTER. 

Specify start point or [Alignment/Reference] <last point>. 

4. Type 0,0 on the command line, and then press ENTER. 

Pick end point or [component List /Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect / Toggle length / Alignment]. 

5. Type @48,0 (@1219,0), and then press ENTER. 

 English units are mentioned first followed by their metric counterpart in parentheses. 
Only type in one set of units: @48,0 or @1219,0. 

6. Right-click and select component List. 

The components list displays. 

7. Select Elbows > [4" (100)] ELL, 90 LR S/STD, ASTM A234 GR WPB. 

Pick other direction. 

8. Move the cursor to the left (going north in the screen) so the elbow is pointing in that direction, 
and then click. There is more pipe showing than is needed, but the next step will clean this up. 

9. Right-click and select component List. 

The components list displays. 

10. Select Flanges > [4" (100)] FLG, RFWN 150LB S/STD BORE, ASTM A-105. 

The flange is placed. 

11. Right-click and select component List. 

The components list displays. 

12. Select Flanges > [4" (100)] FLG, RFWN 150LB S/STD BORE, ASTM A-105. 

The flange, bolt, and gasket are placed. 

13. Right-click and select component List. 

The components list displays. 



 CADWorx Plant Tutorial 

 

 

CADWorx Plant Tutorial 11 
 

14. Select Tees > [4" (100)] TEE, STR. S/STD, ASTM A-234 GR WPB. 

Pick direction or [Change connection]. 

15. Select a direction to the east, and then click. 

Your drawing should resemble the drawing below. Conceptual view was used for clarity. Your 
drawing appears in wireframe. 

 

The tee is placed, and the program places you back at the north point of the model on the 
other end of the tee. 

You will now continue routing to finish the model. 

1. Type 22 (558) on the command line, and then press ENTER.  

The piping shows up coming off the main of the tee.  

2. Right-click and select component List. 

The components list displays. 

3. Select Elbows > [4" (100)] ELL, 90 LR S/STD, ASTM A234 GR WPB. 

Pick other direction. 

4. Select the direction to the west to parallel this elbow with the previous elbow. 

The elbow is placed. 

5. Type .X on the command line, and then press ENTER. 

of. 

6. Select the end of the first pipe line that you drew.  

of (need YZ). 

7. Click west of the new pipe, and then press ENTER. 

8. Click the View tab, and then select SE Isometric  in the Views palette. 
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Your drawing should look like this.  

 

 

9. Click the branch of the tee, and then select the plus  sign. 

10. Right-click and select component List. 

The components list displays. 

11. Select Elbows > [4" (100)] ELL, 90 LR S/STD, ASTM A234 GR WPB. 

Pick other direction. 

12. Pick a direction upward. 

The elbow appears, and depending on where your cursor is placed, some piping might 
appear. 

13. Type 12 (305) on the command line, and then press ENTER. 

14. Right-click and select component List. 

The components list displays. 

15. Select Tees > [4" (100)] TEE, STR. S/STD, ASTM A-234 GR WPB. 

Pick direction or [Change connection]. 

16. Pick a direction to the west (parallel with) the elbow below. 

Your drawing should look like this. 

 

When you insert a reducing component--such as the concentric reducer--the main size and the 
reduction size default large to small providing the proper connection at the reducer. After inserting 
a reducing component the main size and the reduction size reverse. This allows placement of 
other components on the pipe run without having to reset the sizes. 

1. Click the branch of the tee, and then select the plus  sign. 

2. Right-click and select component List. 
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The components list displays. 

3. Select Reducers > Concentric Reducing Buttweld > [4" X 3" (100 X 80)] REDUCER, 
CONC S/STD, ASTM A-234 GR WPB. 

4. Right-click and select component List. 

The components list displays. 

5. Select Flanges > [3" (80)] FLG, RFWN 150LB S/STD BORE, ASTM A-105. 

 

The main size is now set to 3" (80), and the reduction is set to 4" (100).   

6. Continue to model the remaining components--the gate valves, elbows, and additional 
piping-- as shown below. The Reducer is 4" X 3" and we need to use the Change connection 
option to place the branch of the second Tee as it appears in the drawing.   

 

 To further improve the view of the drawing, use the View > 3D Views > SW Isometric 

 command and give the drawing another viewpoint.  
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Your finished piping system in 3D space should look like this. 

 

7. Click Save As . Alternatively, type SAVEAS on the command line, and then press ENTER. 

The Save Drawing As dialog box displays. 

8. Type a name for the drawing, and then click Save. 
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Mode conversion 
Mode conversion converts components from one mode to another mode or to the same mode. 
Mode conversion can also restore a component to its original state after the component has been 
modified. In Route Modeling (on page 10), you created the 3D Solids model shown below. In this 
lesson, you will convert that model to a 2D Double Line. Mode conversion also shows you where 
all your bolts, gaskets, and welds are located with easy viewing. 

  

1. To define the drawing mode, click Setup  on the Settings toolbar. On the CADWorx Plant 
Setup dialog box, select the required option under Drawing Mode. Alternatively, type SETUP 
on the command line, and then press ENTER.  

2. Do one of the following: 

 Open the drawing you completed in the lesson Route Modeling (on page 10).  

 Open the [Product Folder]\Tutorial\Tutor2.dwg file delivered with the software. 

 To work in metric units of measure, open the [Product 
Folder]\Plant\Tutorial\Tutor2m.dwg file.   

3. Click the CADWorx Plant I tab, and then click 2D Double Line  on the Setup Size/Spec 
panel. Alternatively, type CONVERTDOUBLE on the command line, and then press ENTER. 

Select components to convert to double line mode. 

4. Pick a point in the upper right corner of the drawing. 
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Select components to convert to double line mode: Specify opposite corner. 

5. Pick a point in the opposite corner to create a select set that contains all of the model 
components.  

Select components to convert to double line mode: Specify opposite corner: 73 found, 73 
groups. 

6. Press ENTER to end the selection. 

CADWorx converts the model to 2D Double Line. 
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Assembly Modeling 
In this lesson, we will create discharge piping for two pumps using the Assembly Manager 
palette. Although we can draw the piping anywhere, we recommend that it be drawn using the NE 
Isometric view in the tutorial drawing file. Doing so allows for easy placement of the pumps. For 
more information on the Assembly Manager, see Assembly View Palette in the CADWorx Plant 
Users Guide. 

 

1. Open the [Product Folder]\Tutorial\Tutor3.dwg file. 

 To work in metric units of measure, open the [Product 
Folder]\Plant\Tutorial\Tutor3m.dwg file. 

The software opens the drawing, which already has a three-dimensional pipe rack outline, a 
set of pumps, a vessel, and a tank. We will use this same drawing to connect the assembly to 
the pumps when finished. 

2. Set drawing parameters (on page 9) as defined below. 

 M = 4" (100mm) 

 R = 6" (150mm) 

 Specification = 150 (150_MM) 

 Drawing Mode = 3D Solids 

 Piping Rules 

 Apply Gasket Insertion Rule = Automatic  

 Apply Bolt Insertion Rule = Automatic 

 Apply Weld Insertion Rule = Automatic - Buttweld and Socket Weld  

3. Click Weld Neck  on the Flanges toolbar to place a 4" (100) flange. Alternatively, type 
FLGW on the command line, and then press ENTER. 

FLG, RFWN 150LB S/STD BORE, ASTM A-105 

Pick start point or [Buttweld end] <last point>. 

4. Select a point in the drawing to place the flange. 

Pick direction. 

5. Select a direction upward. 
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6. Click the newly placed flange, and then select the plus  sign on the face end. 

Pick end point or [component List / Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect / Toggle length / Alignment]. 

7. Right-click and select component List. 

The components list displays. 

8. Select Reducers > Concentric Reducing Buttweld > [6" X 4" (150 X 100)] REDUCER, 
CONC S/STD, ASTM A-234 GR WPB. 

The main and reduction sizes automatically reverse, allowing placement of the next flange 
without changing the pipe sizes (main size now equals 6” (150) and reduction size equals 4” 
(100)). Anytime a reducing component is encountered, the last size that was drawn is 
automatically set to the main setting (4” (100) small end to 6” (100) large end, 6” (100) large 
end drawn last so 6" (100) is used).   

Pick end point or [component List / Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect / Toggle length / Alignment]. 

9. Right-click and select component List. 

The components list displays. 

10. Select Flanges > [6" (150)] FLG, RFWN 150LB S/STD BORE, ASTM A-105. 

Pick end point or [component List / Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect / Toggle length / Alignment]. 

11. Right-click and select component List. 

The components list displays. 

12. Select Flanges > [6" (150)] FLG, RFWN 150LB S/STD BORE, ASTM A-105. 

Using ROUTE, follow the steps below to draw a 6" (150) ball valve and a 6" (150) check valve. 
After drawing the 6" (150) flange onto the check valve, copy the existing piping at a distance of 
6'-0" (1829mm) using the Copy command. 

1. Right-click and select component List. 

The components list displays. 

2. Select Valve > Valves, Ball > [6" (150)] BALL VALVE, 150LB FLG. 

Pick end point or [component List / Slope / Elevation / Plane / Reference /Fitting mode / Undo 
/ Connect / Toggle length / Alignment]. 

3. Right-click and select component List. 

The components list displays. 

4. Select Valve > Valves, Check > [6" (150)] CHECK VALVE, 150LB FLG. 

Pick direction or [Flip direction]. 

5. Pick a direction upwards. 

6. Right-click and select component List. 

The components list displays. 

7. Select Flanges > [6" (150)] FLG, RFWN 150LB S/STD BORE, ASTM A-105. 

Your image should look like the drawing below. 
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Next, we are going to Copy the valve relay (on page 19). 
 

Copy the valve relay 
Now we copy the valve group and place it 6' (1829) to the right. 

1. Type COPY on the command line, and then press ENTER. 

Select objects; Specify opposite corner. 

2. Pick a window around the components. 

Specify opposite corner: 14 found, 14 groups 

Select objects. 

3. Press ENTER to finish the select set. 

Specify base point or [Displacement/mOde] <Displacement>. 

4. Pick the center base of the bottom flange. 

Specify second point or [Array] <use first point as displacement>. 
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5. Drag the mouse to the right, type 6' (1829) on the command line, and then press ENTER. 

6. Press ENTER when finished. 

The copy appears in the drawing. Zoom out if you cannot see it. 

 

Next, you are going to Finish the discharge piping assembly (on page 21). 
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Finish the discharge piping assembly 
In this lesson we are going to finish the assembly. 

1. Click the flange at the top of the copied component group, and then select the plus  sign on 
the face end. 

2. Right-click and select component List. 

The components list displays. 

3. Select Elbows > Elbows, 90 > [6" (150)] ELL, 90%%D LR S/STD, ASTM A-234 GR WPB. 

Pick other direction. 

4. Select the direction toward the original component group to the east. Alternatively, you can 
click the end point of the original component to ensure the elbow is pointed in the correct 
direction. 

Pick end point or [component List / Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect / Toggle length / Alignment]. 

5. Type CONNECT on the command line, and then press ENTER. 

Pick point. 

6. Select the end point of the flange on the original component group. 

Enter an option [Type/Polyline]<Polyline>. 

7. Press ENTER to accept the default. 

Piping and an elbow are added to the drawing. 

8. Delete the new elbow and the weld gaps associated with it on both the flange and the pipe. 

9. Click the flange at the top of the original component group, and then select the plus  sign 
on the face end. 

10. Draw a piece of pipe going up. 

11. Click the new pipe, and then select the plus  sign in the middle. 

A tee appears on the piping. 

12. Select the piping end point coming from the copied component group. 

Pick branch end direction. 

13. Select the piping end point coming from the copied component group. 

14. Press ENTER to finish. 

15. Click the pipe coming from the copied component group, and then select the plus  sign at 
the end. 

16. Connect the pipe to the tee. 

17. Delete the extra piping from the tee, including the weld gap. 

18. Click the tee, and then select the plus  sign at the top. 

19. Right-click and select component List. 

The components list displays. 

20. Select Elbows > Elbows, 90 > [6" (150)] ELL, 90%%D LR S/STD, ASTM A-234 GR WPB. 

Pick other direction. 

21. Select a direction to the north, and then press ENTER to finish. 
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The drawing should look like this. 

 

Now that we are finished, Create the Assembly (on page 22) using the ASSEMBLYVIEW 
command. 
 

Create the Assembly 
Now that the model is complete, we can add it to the Assembly Viewer. 

1. Click Assembly View . Alternatively, type ASSEMBLYVIEW on the command line, and 
press ENTER. 

The CADWorx Assembly Manager displays. 

2. Click Create Assembly . 

Select components. 

3. Pick a window around the components. 

Select components: Specify opposite corner: 39 found, 39 groups. 

4. Press ENTER to finish selection. 

Pick insert point. 

5. Select the end point of the right or left bottom flange. These points will be used later to connect 
to a pump. 

Enter Assembly name. 
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6. Type Pump Connection on the command line, and press ENTER. 

The Pump Connection is saved to the Assembly Manager, and displays in the Assemblies 
box. 

If you want to save the drawing to your drawings folder, do the following: 

1. Click Save As . Alternatively, type SAVEAS on the command line, and then press ENTER. 

The Save Drawing As dialog box appears. 

2. Type a name for the drawing, and click Save. 

Continue to Placing an assembly using the Assembly Manager (on page 23). 
 

Placing an assembly using the Assembly Manager 
In this lesson we add the discharge piping to the pumps in the Tutor 3 model. 

1. Open the [Product Folder]\Plant\Tutorial\Tutor3.dwg file delivered with the software. If you 
already have this open then skip to step 2. 

 To create a drawing based on metric units, open the [Product 
Folder]\Plant\Tutorial\Tutor3m.dwg file. 

2. Set drawing parameters (on page 9) as defined below. 

 M = 4" (102mm) 

 R = 6" (152mm) 

 Specification = 150 (150_M) 

 Drawing Mode = 3D Solids 

3. Click the View tab, and then click NE Isometric  in the Views panel. 

4. Click Assembly View . Alternatively, type ASSEMBLYVIEW on the command line, and 
press ENTER. 

The CADWorx Assembly Manager displays. 

5. Select Pump Connection from the list of available assemblies, and then click Insert 

selected assembly . 

The assembly appears in the drawing. 

6. Connect the assembly with the pumping as shown in the drawing below.  

Pick direction. 

7. Select a point in the drawing above the pump. 

Pick other direction. 

8. Select a direction south towards the pipe rack. 
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Your model should look like this. 

 

9. Click Save As . Alternatively, type SAVEAS on the command line, and then press ENTER. 

The Save Drawing As dialog box appears. 

10. Type a name for the drawing, and click Save. 
 

Routing pipe on a pipe rack 
In the drawing that we use for this lesson, the T.O.S. (top of steel) of the pipe rack is at 12’-0” 
(3658mm). From the last 6” (150) elbow on the discharge piping, more piping is required. 
Placement of the 6” (150) pipe must be 1’-0” (305mm) from the edge of the pipe rack.   

1. Do one of the following: 

 Open the completed drawing from Placing an assembly using the Assembly Manager (on 
page 23). 

 Open the [Product Folder]\Tutorial\Tutor5.dwg file delivered with the software. 

 To work in metric units of measure, open the [Product 
Folder]\Plant\Tutorial\Tutor5m.dwg file. 

 Keep the drawing in the SE Isometric view during these steps. 
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2. Click the elbow at the top of the pump connection and select the available plus  sign. 

Pick end point or [component List /Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect /Toggle length / Alignment]. 

3. Pull the pipe towards the pipe rack and type 9'2" (2794mm). 

 

4. Right-click and select component List. 

The components list displays. 

5. Click Elbows > Elbows, 90 > [6" (150)] ELL, 90%%D LR S/STD, ASTM A-234 GR WPB. 

Pick other direction. 

6. Select a point above the components. 
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7. Model the piece of pipe up from the elbow, and then press ENTER. 

8. Click the View tab, and then select Front  from the Views panel.  

9. Select the pipe that extends up from the pipe rack, and then click the top grip point below the 

plus  sign as shown below. 
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10. Drag the pipe down to the top of the pipe rack so that it is on the same line. 

 

11. Click the pipe again, and then select the plus  sign at the top. 

Pick end point or [component List /Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect /Toggle length / Alignment]. 

12. Type A for alignment on the command line, and then press ENTER.  

Enter an option [Center/BOP/TOP/Left/Right]<Center>. 

13. Type BOP on the command line, and then press ENTER. 

Pick end point or [component List /Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect /Toggle length / Alignment]. 

14. Pull the pipe to the left, type 12’ (3658mm) on the command line, and then press ENTER. 

15. Press ENTER to finish. 

The piping line is established. 

16. Click View > 3D View > Southeast .  
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The drawing should look like this. 

 

17. Click Save As . Alternatively, type SAVEAS on the command line, and then press ENTER. 

The Save Drawing As dialog box appears. 

18. Type a name for the drawing, and click Save. 
 

Insert components 

Set up the drawing 

1. Do one of the following: 

 Open the completed drawing from Routing pipe on a pipe rack (on page 24). 

 Open the [Product Folder]\Tutorial\Tutor6.dwg file delivered with the software. 

 If you are working in metric units, open the [Product 
Folder]\Plant\Tutorial\Tutor6m.dwg file. 

2. Set drawing parameters (on page 9) as listed below: 

 Main size -  6" (150mm) 

 Reduction size - 8" (200mm) 

 Specification - 150 (150_MM) 

Follow these steps to place a 6” (150mm) flange on the 6” (150mm) nozzle. We must use the 
center of object snap to select the face of the nozzle. Check that the Apply Gasket Insertion 
Rule is set to Automatic in Piping Rules. 

1. Click the View tab, and then select Front  from the Views panel.  

2. Click the CADWorx Plant I tab, and then select Spec View from the Palettes panel.  

The CADWorx Spec View palette displays. 

3. Click Valves, Relief > RELIEF VALVE, 150LB X 150LB FLG [2-24 (50-600)]. 
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Pick point or [Length/Pressure/Relief/Corner]. 

4. Select the center point of the nozzle on top of the vertical vessel. 

Pick relief end direction. 

5. Pick a direction to the right towards the pipe rack. 

6. Select the previously placed relief valve, and then select the plus  sign on the relief end. 

7. Right-click and select component List. 

The component list displays. 

8. Click Flanges > [8" (200)] FLG, RFWN 150LB S/STD BORE, ASTM A-105. 

Pick end point or [component List / Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect / Toggle length / Alignment]. 

9. Drag the piping to the right (towards the pipe rack), and then type 2'10.25" (869.95) on the 
command line. 

10. Right-click and select component List. 

The component list displays. 

11. Click Elbows > Elbows, 90 > 8" (200) ELL, 90%%D LR S/STD, ASTM A-234 GR WPB. 

Pick other direction. 

12. Drag downwards along the vertical vessel, click, and then type 61'-5.875" (18742.03). 

The drawing should look like this. 

 

13. Right-click and select component List. 

The component list displays. 

14. Click Elbows > Elbows, 90 > 8" (200) ELL, 90%%D LR S/STD, ASTM A-234 GR WPB. 

Pick other direction. 

15. Drag towards the pipe rack away from the vertical vessel, click, and then type 10'5" (3175). 

16. Right-click and select component List. 

The component list displays. 

17. Click Elbows > Elbows, 90 > 8" (200) ELL, 90%%D LR S/STD, ASTM A-234 GR WPB. 

Pick other direction. 

18. Select a direction downward towards the pipe rack, and then click. 

19. Change the view to SE Isometric . 

20. Select the previously placed elbow, and then select the plus  sign on the bottom. 

21. Right-click and select component List. 

The component list displays. 
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22. Click Tees > Tee Reducing Buttweld > [12"x8"(300-200)] TEE, REDUCING S/STD, ASTM 
A-234 GR WPB. 

Pick direction or [Change connection]. 

23. Type CHANGE on the command line, and then press ENTER. 

Pick direction or [Change connection]. 

24. Select a direction to the right, parallel with the pipe rack. 

The drawing should look like this. 

 

Pick end point or [component List / Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect / Toggle length / Alignment]. 

25. Type ALIGNMENT on the command line, and then press ENTER. 

26. Type BOP on the command line, and then press ENTER. 

27. Drag the pipe to the end of the pipe rack on the right side, and then press ENTER to finish. 

28. Click the tee again, and then select the plus  sign on the left. 

29. Type ALIGNMENT on the command line, and then press ENTER. 

30. Type BOP on the command line, and then press ENTER. 

31. Drag the piping to the left end of the pipe rack, and then press ENTER to finish. 
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The drawing should look like this. 

 

Continue to Connect the piping from the horizontal vessel to the pumps (on page 31). 
 

Connect the piping from the horizontal vessel to the pumps 
Next, the horizontal vessel requires piping all the way to the pumps that we created earlier. 

1. Set drawing parameters (on page 9) as listed below: 

 Main size -  6" (150mm) 

 Reduction size - 8" (200mm) 

 Specification - 150 (150_MM) 

Next, attach a 6" (150mm) pipe run to the nozzle on top of the horizontal vessel. First, we must 
place a flange on the nozzle and then the gasket and bolts are automatically added based on our 
piping rules. Draw a piece of pipe from the flange, and then another elbow, as shown in the figure 
below. After that, follow the steps to stretch the piping to the same BOP as the 8” (200mm) pipe. 

1. Click the View tab, and then select Front  from the Views panel.  

2. Click the CADWorx Plant I tab, and then select Spec View  from the Palettes panel.  

The CADWorx Spec View palette displays. 

3. Click Flanges > [6" (150)] FLG, RFWN 150LB S/STD BORE, ASTM A-105. 

Pick start point or [Buttweld end] <last point>. 

4. Click the center point of the nozzle on the top of the horizontal vessel. 

The flange is placed. 
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5. Click the newly placed flange, and then select the plus  sign at the top. 

Pick end point or [component List / Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect / Toggle length / Alignment]. 

6. Pick a direction upward, and type 2'-5.8125" (757.24). 

Pick end point or [component List / Slope / Elevation / Plane / Reference / Fitting mode/ Undo 
/ Connect / Toggle length / Alignment]. 

7. Right-click and select component List. 

The component list displays. 

8. Click Elbows > Elbows, 90 > [6" (150)] ELL, 90%%D LR S/STD, ASTM A-234 GR WPB. 

Pick other direction. 

9. Pick a direction toward the rack. 

The drawing should appear similar to the example below. 

 

Next, finish the connection to the 6” (150mm) pipe on the rack.  

1. Pick a direction to the right, and type 30'-7" (9321.8). 

2. Right-click and select component List. 

The component list displays. 

3. Click Elbows > Elbows, 90 > [6" (150)] ELL, 90%%D SR S/STD, ASTM A-234 GR WPB. 

Pick other direction. 

4. Pick a direction downward. 

5. Drag the pipe downward, and type 11.0625" (280.99). 

6. Click the View tab, and then click SE Isometric  or NE Isometric  in the Views panel. 
Choose the view that best works for you. 

7. Click the newly placed pipe, and then select the plus  sign at the bottom. 

8. Right-click and select component List. 

The component list displays. 

9. Click Elbows > Elbows, 90 > [6" (150)] ELL, 90%%D SR S/STD, ASTM A-234 GR WPB. 

Pick other direction. 

10. Select a direction down the pipe rack, parallel with the 12" (300) piping. 

Pick end point or [component List / Slope / Elevation / Plane / Reference / Fitting mode / Undo 
/ Connect / Toggle length / Alignment]. 

11. Type ALIGNMENT on the command line, and press ENTER. 

Enter an option [Center/BOP/TOP/Left/Right]<Center>. 

12. Type BOP on the command line, and press ENTER. 
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Pick end point or [component List / Slope / Elevation / Plane / Reference / Fitting mode/ Undo 
/ Connect / Toggle length / Alignment]. 

13. Type CONNECT on the command line, and press ENTER. 

Pick point. 

14. Zoom out and select the point at the end of the 6" (150) piping coming out of the pumps. 

Do you want to shorten the length of the connecting pipe?:[Yes/No]<Yes>. 

15. Type N on the command line, and press enter. 

Enter an option [Type/Polyline]<Polyline>. 

16. Press ENTER to accept the default. 

Select the line to be routed or <Enter for finish>. 

17. Select the line as displayed in the image below. 

 

The Selection box displays. 

18. Click the 3D Polyline with the color box that is the same color as the line we selected above. 

Select the line to be routed or <Enter for finish>. 

19. Press ENTER to finish. 
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The final result should appear similar to the example below. 

 

20. Click Save As . Alternatively, type SAVEAS on the command line, and then press ENTER. 

The Save Drawing As dialog box appears. 

21. Type a name for the drawing, and click Save. 
 

Paper space and CADWorx 
Model space requires that TILEMODE be on, set it to 1. When working in model space, 
non-floating view ports are available. These non-floating view ports are created with the AutoCAD 
VPORTS command. The only way to arrange these view ports is beside each other, similar to a 
tiled floor. Model space is where all CADWorx orthographics, models, isometrics, and so on are 
created. 
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Paper space requires that TILEMODE be set to 0, which effectively turns off model space. When 
working in paper space, floating view ports are available. These floating view ports are created 
with the AutoCAD MVIEW command. Multiple view ports can also be created. Unlike non-floating 
view ports, the floating view ports created with the VPORTS command are able to overlap each 
other. Paper space is used only for annotation and borders. Although it is an entity with a layer, 
size, line type, and so forth, it is helpful to think of the Mview as a hole cut through the paper 
looking into the model space. 

 

The MSPACE command displays as crosshairs while in the view port, and as a pointer when 
outside of the view port. While in this view port, the UCS icon appears as the traditional icon 
(broken pencil if out of plane). 

 

 You can also use the Layout tab at the bottom of the AutoCAD window to enter paper space. 
The Model tab allows you to enter model space.   

 

 To create multiple layouts, right-click the Layout tab, and then select New layout. For 
example, you can create a separate layout for Plan, Elevation, or Section. 

 MSPACE and PSPACE commands can be used only in paper space. MSPACE (model 
space) is used when entering a view port created with the MVIEW command. PSPACE (paper 
space) is used when exiting a view port created with the MVIEW command.  

1. Open the [Product Folder]\Tutorial\Tutor7.dwg file.  

 To create a drawing based on metric units, open the [Product 
Folder]\Plant\Tutorial\Tutor7m.dwg file. 

2. Click Layout1.  

3. Type MVIEW on the command line to create view ports with which to view the model. 

Specify corner of viewport or  

[ON/OFF/Fit/Shadeplot/Lock/Object/Polygonal/Restore/LAyer/2/3/4] <Fit>. 

4. Type 4 on the command line, and then press ENTER. 

Specify first corner or [Fit] <Fit>. 

5. Select the lower left corner of the inside border area. 

Specify opposite corner. 

6. Select the upper right corner of the inside border area. 

Regenerating model. 
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Four Mviews are created. These Mviews are used to create a plan and elevations of the 
pumps. The upper right Mview is used for an isometric view of the pumps. The upper left is 
used for a plan. The lower left is a front elevation, and the lower right is a side elevation. 

 

7. Double click the upper right corner viewport. 

8. Type DDVPOINT on the command line, and then press ENTER. 

The Viewpoint Presets dialog box appears. 

9. Type 315 in the X Axis box, type 30 in the XY Plane box, and then click OK. 

10. Click the View tab, and then click Window  on the Navigate 2D panel. 

Specify first corner. 

11. Pick a point to the left and above the pumps. 

Specify opposite corner. 

12. Pick a point to the right and below the pumps. 

The view zooms in around the pumps. 

13. Click inside the upper left view port to activate it. 

14. Click View > 3D Views > Plan View > Current UCS. Alternatively, type PLAN on the 
command line, and then select the Current UCS option. 

15. Click Plant > Utility > Zoom Factors > Architect > 3/8 = 1’ (metric at 1:20).  

Center point.  

16. Pick a point between the two pumps. 

 If necessary, click Pan  to reposition the view.  

17. Click inside the lower left view port to activate it. 

18. Type DDVPOINT on the command line, and then press ENTER. 

The Viewpoint Presets dialog box appears. 

19. Type 270 in the X Axis box, type 0 in the XY Plane box, and then click OK. This provides a 
front elevation of the pumps.  

20. Click Plant > Utility > Zoom Factors > Architect > 3/8 = 1’-0” (metric at 1:20).  

Center point.  

21. Pick a point between the two pumps.  

22. Click inside the last view port. 

23. Type DDVPOINT on the command line, and then press ENTER. 

The Viewpoint Presets dialog box appears. 
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24. Type 0 in the X Axis box, type 0 in the XY Plane box, and then click OK.  

The view port showing the side of the pumps is adjusted.   

25. Click Plant > Utility > Zoom Factors > Architect > 3/8 = 1’-0” (metric at 1:20).  

Center point.  

26. Click a point between the pipe rack and the pumps. 

 You can perform dimensioning in the view port itself or within paper space. In the view port 
itself, set the AutoCAD setvar DIMSCALE to 0. CADWorx, and AutoCAD automatically size all the 
text, arrow heads, and so on. The setvar DIMASSOC handles all the scaling and sizing of the 
dimensions and also controls the way the dimensions are updated when objects are changed in 
the model space environment. For more information about this setvar, see the AutoCAD 
documentation. 

Align views within the view ports 

1. Click Plant > Utility > MVSetup. Alternatively, type MVSETUP on the command line.  

Enter an option [Align/Create/Scale viewports/Options/Title block/Undo]. 

2. Type A on the command line, and then press ENTER to select the Align option. 

Enter an option [Angled/Horizontal/Vertical alignment/Rotate view/Undo]. 

3. Type H on the command line, and then press ENTER to select the Horizontal alignment 
option.  

Specify basepoint. 

4. Type INT on the command line, and then press ENTER. 

5. Select the column on the pipe rack in the lower right view port. 

Specify point in viewport to be panned. 

6. Type INT on the command line, and then press ENTER. 

7. Select the column of the pipe rack in the lower left view port. 

Enter an option [Angled/Horizontal/Vertical alignment/Rotate view/Undo]. 

8. Type V on the command line, and then press ENTER to select the Vertical alignment option. 

Specify basepoint. 

9. Type INT on the command line, and then press ENTER. 

10. Select the upper pipe rack in the upper left view port. 

Specify point in viewport to be panned. 

11. Type INT on the command line, and then press ENTER.  

12. Select the upper pipe rack in the lower left view port. 

Enter an option [Angled/Horizontal/Vertical alignment/Rotate view/Undo]. 

13. Press ENTER to finish. 

Enter an option [Align/Create/Scale viewports/Options/Title block/Undo]. 

14. Press ENTER. 
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The drawing should resemble the example below. 

 

 

 You can use the Create option of the MVSETUP command to automatically generate all the 
view ports and view adjustments for each one. This lesson demonstrates only the manual 
method.  

 The most efficient way to create profiles is with the AutoCAD SOLPROF command. Using 
solids and the SOLPROF command allows you to create silhouettes of these items in view 
ports. Solids can also be plotted with hidden line removal. For example, the figure above 
shows the four completed views with hidden line removal. To plot this drawing, freeze the 
ViewL layer and set the Paper button active on the status bar (or type PSPACE on the 
command line, and then press ENTER). 

Create a manual isometric drawing 

1. Open the [Product Folder]\Tutorial\Tutor2.dwg file. 

 If you are working in metric units, open the [Product Folder]\Tutorial\Tutor2m.dwg file. 

The status bar indicates that the drawing is in model space. 

2. Click the Layout tab to place the drawing in paper space. 

This environment shows the border. All that is now required is to activate a view port with the 
MVIEW command. Set the ViewL layer current prior to doing the steps below. 

3. Type MVIEW on the command line, and then press ENTER. 

Specify corner of viewport or  

[ON/OFF/Fit/Shadeplot/Lock/Object/Polygonal/Restore/LAyer/2/3/4] <Fit>. 

4. Type INT on the command line, and then press ENTER. 

5. Select the lower left of the available border. 

Specify opposite corner. 

6. Type MID on the command line, and then press ENTER. 

7. Select the upper available border.  
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Regenerating model. 

This cuts a hole through the paper showing the model in the background.   

8. If the model space is not active click Paper on the status bar. Alternatively, double-click on an 
area over the view port.   

The Paper button changes to Model.   

9. Type DDVPOINT on the command line, and then press ENTER. 

The Viewpoint Presets dialog box appears. 

10. Type one of the following values in the From X box: 45, 135, 225, or 315. 

11. Type 35.3 in the XY Plane box, and then click OK. 

This places the model in line with a paper space isometric rotation. 

 Alternatively, you can use any of the View > 3D Views commands to produce the 
same result.  

12. Use the ZOOM, and PAN commands to better position the model within the view port.   

13. After you have finished positioning the view, click Zoom Lock  on the Settings toolbar. 
Alternatively, type ZOOMLOCK on the command line, and then press ENTER.  

 With the AutoCAD setvar DIMSCALE set to 0, you can easily apply dimensions. The 
only requirement is to position the Point and Shoot UCS to the plane that requires 

dimensioning. Click Object on the UCS toolbar, and then select an existing dimension to 
align the UCS.  

14. Increase the setvar DIMTXT variable to 3/16" (4.7625mm) to allow the dimensions to look as 
though they are 1/8" (3.175mm) due to being out of the plane (30-degrees out of view).   
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15. Place a few dimensions, as shown below. 

  

 Placing the top dimensions requires moving the UCS. For example, click Flat  on 
the UCS toolbar, and then pick a corner at one of the upper elbows. 

16. Switch back to Model Space. 

17. Click Plant > Utility > Drawing Control > Elbow Centerline to turn on the option to draw 
centerlines, and provide corners on the elbows to which to dimension.  

18. Click Plant > Accessory > Mode Convert > Isometric to convert the model to isometric. 
Alternatively, type CONVERTISO on the command line, and then press ENTER. 

Select objects. 

19. Pick a point in the upper left corner of the model. 

Specify opposite corner. 

20. Pick a point in the lower right corner of the model. 

Select objects. 
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21. Press ENTER to finish the selection. 

 

 For dimensions that seem upside down, use the following options to place the dimensions 

correctly. Click Flat  on the UCS toolbar, and then type Z on the command line to select the 
Ztext option.  

 To dimension the vertical leg of the model, click North  on the UCS toolbar, and then pick 
a point at the lower elbow. 

 

CAESAR II and CADWorx data transfer 
The CADWorx Plant import and export functions provide a seamless bi-directional link to 
CAESAR II and its pipe stress analysis capabilities. By selecting components in the model 
environment of the drawing, a CAESAR II input file can be created. This input file can be opened in 
CAESAR II and the model geometry modified. After the stress analysis has been performed, the 
input file can be transferred back into the CADWorx Plant drawing environment. During import, the 
software updates or adds the components that were modified in CAESAR II with a skeleton 
geometry that is clearly visible. Components removed in CAESAR II are deleted. Unchanged 
components are not modified. All CAESAR II information is then stored in the drawing providing 
future analysis capabilities based on the previous information (node numbers, temperature, 
pressure, and so forth.). 

In this lesson, you use the import and export features of CAESAR II and CADWorx Plant to create 
a fully annotated stress isometric drawing. The major tasks in this lesson are:  

 Create a CAESAR II input file (on page 41) 

 Modify the input file (on page 43) 

 Import the CAESAR II input file (on page 45) 

 Re-run the job (on page 48) 

 You must have CAESAR II installed on your computer to complete the tasks in this lesson.  
 

Create a CAESAR II input file 
1. Open the [Product Folder]\Tutorial\Tutor11.dwg file.  

 To work in metric units of measure, open the [Product 
Folder]\Plant\Tutorial\Tutor11m.dwg file. 
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The drawing file that opens represents a typical system built in CADWorx Plant that is to be 
sent to CAESAR II. 

 

2. Click Plant > Accessory > CAESAR II > System Out. Alternatively, type C2OUT on the 
command line and then press ENTER.  

 You can also click the CADWorx Plant I tab and then click System Out  on the Misc 
panel. 

The CAESAR II Input File dialog box displays. 

3. Click Save to save the CAESAR II input file with the default name Tutor11.   

Enter an option [Database/Line number/Select components] <Select components>. 

4. Press ENTER to accept the default Select components option. 

Select objects. 

5. Type ALL on the command line, and press ENTER.  

Select objects. 

6. Press ENTER to finish selection. 

Provide start locations [Yes/No] <No>. 

 This prompt allows you to control noding within CAESAR II. For more information, see 
"System Out" in the CADWorx Plant User's Guide. 

7. Press ENTER to accept the default No option. 
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When processing completes, the software displays a message box similar to the example 
below. 

 

8. Click OK to close the message box and return to the drawing. 

The piping layout has been successfully transferred to a CAESAR II input file named 
Tutor11._A. 

 

Modify the input file 
1. Start CAESAR II and open the [Product Folder]\Plant\Tutorial\Tutor11.c2 input file you 

created in Create a CAESAR II input file (on page 41). 

2. Click Input > Piping.  

The Classic Input Piping dialog box displays. 

3. Click Options > Node Numbers. 

The graphic representation of the model updates to display the same piping configuration as 
was in CADWorx Plant.  

4. Click First Element  and then double-click Restraints. 

5. Type 10 in the Node box, and select ANC in the Type list. 

6. Click Next Element  and then double-click Restraints. 

7. Type 30 in the Node box, and select +Y in the Type box. 

A 5’-0” (1524mm) expansion loop is added to the line.   

8. Click Next Element  to move to element 50-60.  

9. Type 15’-0” (4572mm) in the DY box. 

10. Click Next Element  to move to element 60-70, and then enter a single node to place a 
new node for the hanger.   

11. Type 62 in the To box. 

12. Type 3’-0” (914mm) in the DY box as the distance from node 60.   

The only entries required are the new node number and the distance.  

13. Double-click Hanger, and type 62 in the Node box to define a location for the new hanger. 

14. Click Next Element  to move to element 62-70. 

15. Click Model > Break. 

The Break at element 62 - 70 dialog box displays. 
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16. Type 64 in the New Node Number box, type 3'-0" (914mm) in the Distance in box, and click 
OK. 

17. Double-click Bend to place a bend at the end of this location.   

A long radius bend is added to the piping configuration.  

18. Click Edit > Insert to insert another element after 62-64. 

The Insert Element dialog box appears. 

19. Verify that After is selected, and click OK. 

20. Type 66 in the To box. 

21. Type -5'-0" (-1524mm) in the DY box. 

22. Double-click Bend to place a bend at this location. 

23. Click Next Element  to move to element 64-70. 

24. Type 66 in the From box. 

This connects the remaining system to the new node 66 and ties together the loop.  

25. Click Next Element  to move to element 100-110. 

26. Double-click Restraints. 

27. Type 110 in the Node box, and select ANC in the Type list. 

28. Repeat steps 25 through 26 to place anchors on nodes 130 and 150.  

29. Click First Element . 

30. Type 250 F (175 C) in the Temp 1 box. 

31. Type 300 PSI (1000 Kpa) in the Pressure 1 box. 

32. Double-click Allowable Stress. 

33. Select B31.1 in the Code list, and type 20,000 PSI (120,000 Kpa) in the SC and SHI boxes. 

The CAESAR II job should be similar to the example below. 

  

 Use the Restraints, Anchors, and Hangers commands on the Options menu to 
toggle on and off the display of the restraints, anchors and hangers. 

34. Click Start Run  to save the input and start the error checking procedure.  

The error checker software reviews the CAESAR II model and alerts you to any possible 
errors, inconsistencies, or noteworthy items. These items display in a grid as errors, warnings, 
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or notes. The total numbers of errors, warnings, or notes display in corresponding boxes 
above the message grid.  

 The error checking procedure should generate 0 errors, 0 warnings, and 2 notes. Any 
other result indicates an input error and should be resolved before moving on to Import the 
CAESAR II input file (on page 45). 

35. Click File > Exit to close the Classic Piping Input dialog box. 
 

Import the CAESAR II input file 
Next, import the modified input file into CADWorx Plant to update the piping drawing. Some minor 
modifications will be required that should then be sent back to CAESAR II one more time. 

1. Click Plant > Accessory > CAESAR II > System In. Alternatively, type C2IN on the 
command line, and then press ENTER. 

 We can also click the CADWorx Plant I tab, and then click System In  on the Misc 
panel. 

The CAESAR II Input File dialog box displays. 

2. Navigate to the CAESAR II input file, and click Open.  

Please set a default Specification <150>. 

3. Press ENTER to accept the default specification. 

Prepared E:\CADWORX PIPE 2002\SPEC\150.spc specification... 

 The specification is not used here but is always requested by the system as a backup 
default. 

 

After reading the input file, the next prompt requests the level of intervention required. For 
more information, see "System In" in the CADWorx Plant User's Guide.  

Enter an option [Full intervention/Partial/None] <None>: 

Working component number: 34. 

 The areas that have been modified are readily apparent. 

4. Click Plant > Accessory > Mode Convert > 3D Solids to convert the entire model to 3D 
solids. Alternatively, type CONVERTSOLID on the command line, and then press ENTER.  
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 We can also click the CADWorx Plant I tab, and then click 3D Solids  on the Setup 
Size/Spec panel. 

3D solids conversion... 

Select objects. 

5. Type ALL on the command line, and press ENTER. 

Select objects. 

6. Press ENTER to finish selection process. 

7. Click North  on the UCS toolbar to relocate the UCS. Alternatively, type VIEWNORTH on 
the command line and then press ENTER.  

 We can also click the CADWorx Plant II tab and then click North  on the UCS panel. 

[Xtext/Ztext/Elevation/Rotate/COordinate/CLip] <Pick point, or enter>. 

8. Type ENDP on the command line, and press ENTER. 

9. Select the lower end point of the vertical 8" (200mm) pipe to the far right.  

10. Click Plan Tee  on the Buttweld toolbar. Alternatively, type TESW on the command line 
and then press ENTER.  

8" (200) TEE, STR. S/STD, ASTM A-234 GR WPB 

Pick start point or [Branch/Center] <last point>. 

11. Type ENDP on the command line, and press ENTER. 

12. Select the bottom buttweld of the upper right elbow. 

Pick main end direction. 

13. Type @0,-100 on the command line and then press ENTER, or pick a direction in the drawing. 

Pick branch end direction. 

14. Type @100,0 on the command line and then press ENTER, or pick a direction in the drawing. 

15. Click Pipe  on the Buttweld toolbar. Alternatively, type PIPW on the command line, and 
then press ENTER. 

8" (200) PIPE, S/STD SMLS, ASTM A-106 GR B 

Pick start point or [TOP/BOP] <last point>. 

16. Type ENDP on the command line, and press ENTER. 

17. Select the branch connection of the previous drawn tee. 

Pick end point. 

18. Type @36,0 (@914,0) on the command line, and press ENTER. 

19. Click Weld Neck  on the Flanges toolbar to place the weld neck flange. Alternatively, type 
FLGW on the command line, and then press ENTER. 

8" (200) FLG, RFWN 150LB S/STD BORE, ASTM A-105 

Pick start point or [Face end] <last point>.  

20. Press ENTER to accept the last point. 

Pick direction. 

21. Type @100,0 on the command line and then press ENTER, or pick a direction in the drawing. 

8" (200) GASKET, 1/8" THK, 150LB 

Automatically placed... 

22. Click Spring Hanger  on the Restraints toolbar. Alternatively, type SPRING on the 
command line and then press ENTER.  
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 We can also click the CADWorx Plant II tab, and then click Spring Hanger  on the 
Restraints panel. 

Pick location on component for restraint. 

23. Type ENDP on the command line, and press ENTER. 

24. Select the right end of the new horizontal pipe. 

Enter or pick rotation. 

25. Type @0,100 on the command line and then press ENTER, or pick an upward direction in the 
drawing. 

Enter depth. 

26. Type 17 (432) on the command line, and press ENTER. 

Enter length or diameter <1'-5" (432)>. 

27. Press ENTER to accept the default. 

Enter assembly identification number <17.00-3 SPRING HANGER>. 

28. Press ENTER to accept the default. 

 

29. Click Plant > Accessory > CAESAR II > System Out. Alternatively, type C2OUT on the 
command line, and then press ENTER.  

 We can also click the CADWorx Plant I tab, and then click System Out  on the Misc 
panel. 

The CAESAR II Input File dialog box appears. 

30. Click Save to accept the default input file name (Tutor11.c2)  

Enter an option [Database/Line number/Select components] <Select components>. 

31. Press ENTER to accept the default Select components option.  

Select objects.  

32. Type ALL on the command line, and press ENTER. 

Select objects. 
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33. Press ENTER to finish the selection. 

Provide start locations [Yes/No] <No>. 

34. Press ENTER to accept the default No option. 

The software begins transferring the piping layout to the CAESAR II input file. When 
processing completes, the software displays a message box similar to the example shown 
below. 

 
 

Re-run the job 
1. Start CAESAR II, and open the [Product Folder]\Plant\Tutorial\Tutor11.c2 input file.  

2. Click Input > Piping. 

The Classic Piping Input dialog box appears. 

 If necessary, use the Restraints, Anchors, and Hangers commands on the Options 
menu to toggle on and off the display of the restraints, anchors, and hangers. 

3. Click Batch Run  to check the input data, analyze the system, and present the results 
when processing is complete.   

4. View the results. 

5. When we are finished viewing the results, click File > Exit to close the Classic Piping Input 
dialog box and return to the CAESAR II main window. 

6. Click File > Exit to close CAESAR II. 
 

Automatic Dimensioning 
We can create dimensions automatically for a set of components that we select. Options to set the 
offset distance and whether to include flanges are also available. 

 When using automatic dimensioning, we must set the AutoCAD setvars as specified below: 

 Set DIMSCALE to 0 so that the dimension text and arrows automatically size themselves. For 
more information, see Paper space and CADWorx (on page 34). 

 Set DIMASZ to 1/8" (3mm). This value represents a typical plotted size. Within this 
environment, the dimensions should scale correctly. 

 Set DIMTXT to 2" (50mm) 

1. Open the [Product Folder]\Tutorial\Tutor2.dwg file. 
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 To work in metric units of measure, open the [Product 
Folder]\Plant\Tutorial\Tutor2m.dwg file. 

Or 

2. Open the drawing we completed in Route Modeling (on page 10). 

The software opens the drawing, which resembles the example below.  

 

3. Click the CADWorx Plant I tab, and then click 2D Double Line  on the Setup Size/Spec 
Panel. 

Select components. 

4. Select the entire drawing, and then press ENTER to finish. 

The entire drawing is converted to 2D double line. 

5. Select everything above the u shape and extending from the bottom tee, and then delete it. 

6. Click the View tab, and then click Top on the Views panel. 
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The drawing should resemble the one below. 

 

7. Click Plant > Dimension > Automatic. Alternatively, type AUTODIM on the command line, 
and then press ENTER.   

 We can also click the CADWorx Plant II tab, and then click Automatic  on the 
Dimensions panel. 

Enter an option [Flange/Offset/Selection].  

8. Press ENTER for the default or select Selection in the popup menu to select objects to 
dimension. 

 The Flange option allows dimensioning to flange faces. If this option is not selected, 
dimensioning is only to the corners and tees of the piping system. The Offset option allows 
you to adjust the distance from the component to the dimension line. 

Select objects: 

9. Type ALL on the command line, and then press ENTER. 

Select objects:   

10. Press ENTER to finish the select set. 

Pick centroid point of dimensions:   

11. Select the open space in the middle of the U shape. 
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Auto Dimensioning...finished. 

 

  

 Automatic dimensioning requires that the system have at least one turn in it. If the message 
Inadequate selection...aborting *Cancel* appears, then the system is lacking an elbow or 
tee. 

 When modifying dimensions that already exist in the drawing, the UCS Object  command 
can be used to set the UCS and the dimension in the same plane. This makes it easy to 
stretch, grip, and correct overlapping dimensions.  

 We can re-scale dimensions only if the setvar DIMASO is on. If the view port is re-sized by 
zooming, the dimensions can be updated to the correct scale.  

a. Type DIM on the command line, and then press ENTER.  

Dim. 

b. Type DIMTXT on the command line, and then press ENTER. 

Enter new value for dimension variable <3/16">. 

c. Type 0.125 (3) on the command line, and then press ENTER. 

Dim. 

d. Type UPDATE on the command line, and then press ENTER. 

Select objects. 

e. Type ALL on the command line, and then press ENTER. 

Select objects. 
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f. Press ENTER to finish the selection set 

Dim. 

g. Type EXIT on the command line, and then press ENTER. 
 

Bill of Material (BOM) 
In this lesson, we automatically place a Bill of Material schedule and all the associated tags on the 
drawing in paper space. For more specific Bill of Material command reference information, see 
Pipe BOM/DB in the CADWorx Plant User's Guide. 

1. Open the [Product Folder]\Plant\Tutorial\Tutor10.dwg file. 

 For metric units of measure, open the [Product Folder]\Plant\Tutorial\Tutor10m.dwg 
file   

2. Click Plant > Bill of Material > Run > Cut. Alternatively, type BOMCUT on the command 
line, and then press ENTER. 

 We can also click the CADWorx Plant I tab, and then click Cut  on the Pipe 
BOM/DB panel. 

Enter tag option [Counter/Manual placement/Automatic placement] <Automatic>. 

3. Press ENTER to accept automatic placement. 

Select upper right corner of BOM heading. 

4. Pick a point at the corner of the border. 

Enter an option [Line number/Select components] <Select components>. 

5. Press ENTER to accept the default Select components option. 

Select objects. 

6. Select all the objects in the view port. 

Select objects. 

7. Press ENTER to finish. 

A Bill of Material, similar to the example below, is placed on the isometric drawing. 
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 Use the Plant > Bill of Material > Setup command to customize the Bill of Material schedule 
to any style or layout that you need. Alternatively, click the CADWorx Plant I tab, and then 

click Setup  on the Pipe BOM/DB panel, or type BOMSETUP on the command line, and 
then press ENTER. Using the options on the Bill of Material Setup dialog box, you can 
specify column widths, provide the schedule direction (up or down), provide user specified 
headings for columns, allow alignment of columns, and the selection of over 30 different 
entries into the schedule. You can arrange the columns in any order. For more information, 
see Bill of Material Setup in the CADWorx Plant User's Guide. 

 You can use the system variables BOMScheduleDirection, BOMScheduleSpacing, 
BOMTagGridFactor, BOMTagOptimize, BOMTagRadiusFactor, and 
BOMTagSpacingFactor to control the Bill of Material characteristics. For more information, 
see Startup Variables in the CADWorx Plant User's Guide. 

 Use the AutoCAD commands listed below to assist with the placement or relocation of 
material tags.  

 Click Plant > Bill of Material > Tag > Location, or type TAGRELOCATE on the 
command line, and then press ENTER, to relocate material tags manually. The leader to 
the component will also be adjusted with this function.  

 Click Plant > Bill of Material > Tag > Insert, or type TAGINSERT on the command line, 
and then press ENTER, to place a single graphic mark symbol (it will not be consistent 
with the bill of material).  

 Click Plant > Bill of Material > Tag > Toggle, or click TAGTOGGLE on the command 
line, and then press ENTER, to toggle on/off tags Bill of Material tags, similar to the toggle 
for automatic and stress isometrics.  

 The Bill of Material schedule is developed and grouped together. To add lines within the Bill of 
Material schedule, select one of the existing lines, and copy it to the new location. Use the 
AutoCAD DDEDIT command to modify the new line item.  

 The Plant > Bill of Material > Export command extracts the components in the drawing to a 

spreadsheet. Alternatively, click the CADWorx Plant I tab, and then click Export  on the 
Pipe BOM/DB panel, or type BOMEXPORT on the command line, and then press ENTER. 

 If the modeled piping view is panned slightly, the component marks do not show as correct. 
Use the AutoCAD MOVE command to adjust them, and then use the AutoCAD PSPACE 
command to return to paper space. Move the material marks by window, and then select a 
base point at a leader’s endpoint. Next, select a second point of displacement, object snap, 
midpoint of, or the centerline of a component. Object snap mode selection is allowed from 
paper space to model space. This corrects the alignment of the material marks. 

 

Edit components 
1. Click File > Open, and then open the [Product Folder]\Tutorial\Tutor2.dwg file. 

 To work in metric units of measure, open the [Product 
Folder]\Plant\Tutorial\Tutor2m.dwg file. 

2. Click Component Edit  on the Settings toolbar. Alternatively, type CEDIT on the 
command line, and then press ENTER.  

 You can also click the CADWorx Plant I tab, and then click Local Edit  on the Setup 
Size/Spec panel. 

Select objects. 

3. Select a section of pipe, and then press ENTER. 
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The Component Edit dialog box for the selected component type appears. 

4. Make changes as needed, and then click OK to save the modifications. 

  

 Alpha size is used only to define the alpha description. It does not allow the physical size of 
the component to be changed. There is no automatic mechanism that changes all 
components from one size to another.  

 Weight allows you to change the weight per unit of pipe. For other components, the value in 
the Weight box indicates the total weight.   

 Sort sequence is used for the Bill of Material. If the location of a component in the Bill of 
Material must be last, type 999 in the Sort sequence box. 

 Remove allows the data inside of the component to be removed. You can use this option for 
marking existing piping within a new plan or piping drawing. The information is removed 
permanently. 

 The options in the Coordinates section allow the length of the pipe to be altered. This does 
not change the physical length on the drawing, only the length that appears in the Bill of 
Material. If you select the Iso option, the Length box becomes available, allowing you to enter 
a new value. Stretching the component does not change the length recorded inside of it. If the 
Iso option is not used, and the component was stretched, the length updates automatically.  

 The Existing option in the Miscellaneous section places the component in a state where it 
does not appear in the Bill of Materials, but it retains all of its information. This option also 
converts the component to the Exist layer (installation layer name). The CAESAR II option 
indicates whether the component has stress analysis information attached, and allows it to be 
removed if this box is un-checked. 

 

Specification Editor 
This tutorial demonstrates how to use the Specification Editor to create a new catalog and a new 
project specification. It also demonstrates how to change a delivered specification for use with a 
customer. The first tutorial demonstrates how to create a catalog from beginning to end. The next 
tutorial does the same for a project specification. Also included is a demonstration on how to 
update an existing project specification or catalog for a client. Lastly, we demonstrate how to use 
optional components, which can be toggled on or off. The Specification Editor is meant to allow 
companies to create specialized data for each of their clients. It is also meant to allow for 
component sizes that are not delivered with the specification to be added to that specification.        

 If you have a specification presently set in CADWorx when you open the Spec Editor, it is 

automatically loaded. If it is not presently set, use Setup  on the Setup Size/Spec panel to set 
it. For more information, see Specification and Size in the CADWorx Plant User's Guide. 
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Create a New Catalog 
In the following lesson we create a catalog from scratch for Cantor Piping. They have specific 
sizes that they do not want allowed in their piping ranges.   

1. Open the Spec Editor , and click File > New Catalog . 

The New Catalog dialog box displays. 

2. Type Cantor Piping 625 in the Name box. 

3. Select Company Catalog from the Type list. 

4. Select the Base Catalog ellipsis, then select Sample_Inch.cat (Sample_Metric.cat), and 
click Open. 

5. Type Catalog for Cantor Piping products in the Description box. 

6. Check that the Location box is linked to the Spec folder. 

7. If working in Metric, change the Units to Metric/Metric. If not, then leave them at 
English/Inch. 

8. Click OK. 

Now Add a size table (on page 55) to the new catalog. 
 

Add a size table 

1. Click the Home tab, and then click Size Table  on the Add Table panel. Alternatively, 

right-click Size Tables in Catalog Data, and then select Add Size Table . 

The New Size Table dialog box displays. 

2. Type Size in the Name box. 

3. Type Main sizes for components in the Description box. 

4. Accept the Default Part Number. 

 The Current Units box will be grayed out and should contain the units currently 
associated with the open catalog. 

5. Click OK. 

The new size table displays in the main screen with the description we typed in at the top left. 
It is also added to Catalog Data under Size Tables. 

We now need to add the new sizes for all the components that will later be added to this catalog. 

1. Right-click in the main window, and then click Add Standard Size. 

The Select size from template dialog box displays. 

2. Click the Select / deselect all check-box to add all sizes, and then click OK. 

The sizes selected are displayed in the main window. 

Now we will add a new size to the table. 

1. Right-click in the main window, and then click Add New Size. 

An empty line is displayed at the bottom of the list. 

2. Type 16.5000 (425) under NOM. 

3. Type 17.0000 (450) under OD. 

4. Type "16 1/2" ("425mm") under DESCRIPTION. 
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5. Type 0044 under PTN. 

6. Save the catalog by clicking File > Save. 

Now Add a material table (on page 56) to the catalog. 
 

Add a material table 

1. Click the Home tab, and then click Material Table  on the Add Table panel. 
Alternatively, right-click Material Tables in Catalog Data, and then select Add Material 

Table . 

The New Material Table dialog box displays. 

2. Type MAT in the Name box. 

3. Type Materials table for Cantor in the Description box. 

4. Click OK. 

The new material table displays in the main screen with the description you typed in at the top 
left. It is also added to Catalog Data under Material Tables. 

We now insert a row for the material used by Cantor Piping. 

1. Right-click in the main window, and then click Insert Row. 

An empty line is displayed.   

2. Type A312 under SPEC.  

3. Type TPXM19 under GRADE.  

4. Type 22Cr-13Ni-5Mn under COMPOSITION. 

5. Type 0.2830 under DENSITY. 

6. Type Caps,Elbows,Tees,Crosses,Valves,Flanges,Gaskets/Bolts/Welds under 
COMPTYPES. 

7. Type 0201 under PTN. 

8. Save the catalog by clicking File > Save. 

Now Add a schedule table (on page 56) to the catalog. 

Add a schedule table 

1. Click the Home tab, and then click Schedule Table  on the Add Table panel. 
Alternatively, right-click Schedule Tables in Catalog Data, and then select Add Schedule 

Table . 

The New Schedule Table dialog box displays. 

2. Type SCH in the Name box. 

3. Accept the Default Part Number. 

4. Type Schedule for Cantor in the Description box. 

5. Click OK. 

The new schedule table displays in the main screen with the description you typed in at the 
top left. It is also added to Catalog Data under Schedule Tables. 

Now add the schedule 
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1. Right-click in the main window, and then click Add Schedule. 

The Add Schedule Items dialog box displays. 

2. Hold CTRL, and select 5S, 5, 10S, 40S, 100, 120, and 140 from the Standard Items list, and 
click the Add arrow to add them to the Selected Items list.  

3. Click New , type 130, and then click OK. 

The schedule items are added to the list. 

4. In the PTN box, type 001, 002, 003, 004, 005, 006, 007, and 008 respectively for each 
schedule. 

5. Save the catalog by clicking File > Save. 

Next Add a thickness table (on page 57) to the catalog. 
 

Add a thickness table 

1. Click the Home tab, and then click Thickness  on the Add Table panel. Alternatively, 

right-click Thickness Tables in Catalog Data, and then select Add Thickness Table . 

The Thickness Table dialog box displays. 

2. Type THICK in the Name box. 

3. Select Size from the Size Table list. Most likely this is the default. 

4. Select SCH from the Schedule Table list. Most likely this is the default. 

5. Type Thickness Table for Cantor in the Description box. 

The new thickness table displays in the main screen with the description we typed in at the top 
left. It is also added to Catalog Data under Thickness Tables.  

 The new table brings in all the Nominal sizes from the size table, and the schedule 
numbers from the schedule table. 

Now add thickness amounts to 100, 120, and 140. 

1. Click the block at the intersection of 100 and 24.0000 (600), and then type 1.5310 (38.887). 

2. Click the block at the intersection of 120 and 10.0000 (250), and then type 0.5000 (21.412). 

3. Click the block at the intersection of 140 and 8.0000 (200), and then type 0.8120 (20.625). 

Now Add an end type table (on page 57) to the catalog. The EndType table we are going to add is 
for a Flange. 
 

Add an end type table 

1. Click the Home tab, and then click EndType Table  on the Add Table panel. 
Alternatively, right-click EndType Tables in Catalog Data, and then select Add EndType 

Table . 

The New EndType Table dialog box displays. 

2. Type BW_11EN_EXA in the Name box.   

3. Select Buttweld from the Type list. 

4. Select Size from the Size Table list. 

5. Click the Size Table ellipsis. 

The Select Size dialog box displays.  
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6. Select 2.0000, 4.0000, 6.0000 (50, 100, 150) from the list, and then click OK. 

7. Type 0013 in the Part Number box. 

8. Type EndType Buttweld table for Cantor in the Description box. 

9. Click OK. 

The new end type table displays in the main screen with the description we typed in at the top 
left. It is also added to Catalog Data under End Type Tables. 

The columns are empty so now we must input the rest of the information. 

1. In the 2.0000 (50) row, type 1.5000 (38.1000) under OAL and FACELEN, and then type 
6.0000 (152.4000) under CFD and FFD.  

2. Highlight the row from OAL to FFD, right-click, and then select Copy. 

3. Highlight the 4.0000 (100) row from OAL to FFD, right-click, and then select Paste. 

4. Repeat step 3 for the 6.0000 (150) row. 

Now Add a category (on page 58) to the Data Tables file. We must add a category to the Data 
Tables file before we can add new data tables. 

Add a category 

1. Click the Home tab, and then click Category Table   in the Add Table panel. 

Alternatively, right-click Data Tables in Catalog Data, and select Add Category . 

The Add Category dialog box displays. 

2. Click the Category list, and then select Elbows. 

3. Type Cantor Elbows in the Description box. 

4. Click OK. 

The new category is added to Data Tables in Catalog Data. 

Now that we have added the category we can Add a data table (on page 58) to that category. 

Add a data table 

1. Click the (+) sign on the Data Tables file in Catalog Data.  

The Data Tables file expands displaying the categories. 

2. Select Elbows. 

3. Click the Home tab, and then click Data Table  on the Add Tables panel. Alternatively, 

right-click a category in Data Tables in Catalog Data, and then select Add Data Table 
.  

The New Data Table dialog box displays. 

4. Type 90L_W_S_STD in the Name box. 

5. Click the Type list, and then select Short Radius Elbow.  

6. Click the Size Table list, and then select Size. 

7. Click the Size Table ellipsis. 

The Select Size dialog box displays.  

8. Select 2.0000, 4.0000, 6.0000 (50, 100, 150) from the list, and then click OK. 
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9. Click Apply same end-type on all ends. This option grays out all but the Start end type 
option. 

10. Click the Start list, and select BW_11EN_EXA. This is the end type we created earlier.  

 If this were a cross or a tee we would also be able to enter the Left, and Right end 
types, unless we selected Apply same end-type on all ends. 

 Make sure that the selected EndType tables contain data in accordance with the 
new component size range. 

11. Type 0012 in the Part Number box. 

12. Type Cantor's Buttweld Elbows in the Description box. 

13. Click OK. 

The new data table appears in the main screen with the name in the upper left corner, and in 
the Catalog Data under the category we selected. 

The columns are empty so now we must input the rest of the information. 

1. In the 2.0000 (50) row, type 3.0000 (80) under RAD, and 90.00 under ANG.  

2. Type 1.5000 under WEIGHT, and 3 under ETS.  

3. Highlight the row from RAD to ETS, right-click, and then select Copy. 

4. Highlight the 4.0000 (100) row from RAD to ETS, right-click, and then select Paste. 

5. Repeat step 3, and 4 for the 6.0000 (150) row. 

The New Catalog is finished. Feel free to practice this process.   

Edit an existing catalog 
In the following lesson, we add information to an existing catalog for a company called DJ Piping. 
We can take existing catalogs and save them separately for different companies that require 
different components.   

1. Click File > Open . 

2. Click Sample_Inch.cat, and click Open. 

3. Click File > Save As . 

 If you do not save changes to a different file, then you are making changes to a 
delivered product. If you save these changes directly to Sample_Inch.cat you might have to 
re-install CADWorx to return your setup to default. We highly recommended that you save this 
using another name before continuing. 

4. Type Inch Example Tutorial, and click Save. You can choose to save this outside of the 
Spec Folder in a folder on your computer. 

If you want to practice adding new tables to an existing catalog use the steps in Create a New 
Catalog (on page 55). The following tutorial demonstrates how to edit a Size table, a Schedule 
table, and a Data table. We also edit the properties for some of the options. 

1. Select Size under Size Tables in Catalog Explorer.  

The table displays to the right of the Catalog Explorer.  

2. Hold CTRL, and select the 2.5000, 5.0000, 16.0000, and 38.0000 (65, 125, 400, 1000) rows.  

3. Right-click on a row, and then click Remove Row.. 

The Remove dialog box displays. 

4. Click OK. 

The 2.5000, 5.0000, 16.0000, and 38.0000 (65, 125, 400, 1000) rows are removed. 
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5. Right-click Size, and select Properties. Alternatively, click the View tab, and then select 
Properties in the Display panel. 

The Properties window opens. 

6. Click the word Size next to Table Name, and then delete it. 

7. Type DJ Piping Sizes Allowed, and, then click anywhere in the screen. 

The Size Table name changes. 

8. Type your name in the Edited By box. 

9. Type DJ Piping Requested Sizes in the Description box. 

Now we are going to edit a Schedule table. 

1.  Click SCH under Schedule Tables in Catalog Explorer.  

The table displays to the right of the Catalog Explorer.  

2. Hold CTRL, and select the 5S, 5, XXS, and STD rows.  

3. Right-click on a row, and then click Remove Row. 

The Remove dialog box displays. 

4. Click OK. 

The 5S, 5, XXS, and STD rows are removed. 

5. Right-click SCH, and select Properties. Alternatively, click the View tab, and then select 
Properties in the Display panel. If you are doing this the same time as the last one then the 
Properties window will already be open. 

The Properties window opens. 

6. Click the word SCH next to Table Name, and then delete it. 

7. Type DJ Piping Schedule, and then click anywhere in the screen. 

The Size Table name changes. 

8. Type your name in the Edited By box. 

9. Type DJ Piping Requested Schedule in the Description box. 

Now we are going to edit a Data table. 

1. Click the + sign next to Flanges under Data Tables in Catalog Explorer. 

2. Click the + sign next to Flange Weld Neck. 

3. Double-click FLG_W_150. 

The table displays to the right of the Catalog Explorer.  

4. Hold CTRL, and select the 2.5000, 5.0000, and 16.0000 (65, 125, 400) rows.  

5. Right-click on a row, and then click Remove Row. 

The Remove dialog box displays. 

6. Click OK. 

The 2.5000, 5.0000, and 16.0000 (65, 125, 400) rows are removed. 

7. Right-click FLG_W_150, and select Properties. Alternatively, click the View tab, and then 
select Properties in the Display panel. If you are doing this the same time as the last one the 
Properties window will already be open. 

The Properties window opens. 

8. Click the word FLG_W_150 next to Table Name, and then delete it. 

9. Type DJ Piping 150 WN Flg, and, then click anywhere in the screen. 

The Size Table name changes. 

10. Type your name in the Edited By box. 



 CADWorx Plant Tutorial 

 

 

CADWorx Plant Tutorial 61 
 

 

Create a New Project 
In this lesson we create a project specification for Ezz Piping. There are certain component groups 
that Ezz Piping does not allow the pipers to use. 

1. Open the Spec Editor , and click File > New Project . 

The New Project dialog box displays. 

2. Type Ezz Piping Spec in the Name box. 

3. Click the Default Catalog ellipsis, select Sample_Inch.cat, and click Open. 

4. Select Fabrication from the BOM (Bill of Material) type list.  

5. Click Long Desc Format. 

The Long Description Format dialog box displays. 

6. Select Components from the list. 

7. Select Components Tables from the list. 

8. Use the right  arrow to move COMPTYPE_CMP_TBL, and TABLENAME_CMP_TBL from 
Table Fields to Long Desc. 

9. Click OK when finished. 

10. Click Part Number Format. 

The Part Numbers Format dialog box displays. 

11. Use the right  arrow to move COMPONENT_PTN, and ENDTYPE_PTN from Available 
Part Number Fields to Selected Part Number Fields. 

12. Click OK when finished. 

13. Type Specification settings for Ezz Piping in the Description box. 

14. Check the location. If you do not want to save the project to the Spec folder click the ellipsis, 
and save it where you want. 

15. Click OK to create the new project. 

The project is created, and displays under Project Data. 

Now we need to Add specification to the project (on page 61). 

 
 

Add specification to the project 

1. Click the Home tab, and then click Add Specification  on the Specification panel. 
Alternatively, right-click the project name in the Project Data window, and click Add 
Specification. 

The New Specification dialog box displays. 

2. Type 150_EZZ PIPE in the Name box. 

3. Type 5 in the Weight Factor box.  

 The weight factor is used for adding various margins into component weights such as 
paint and weld weights. 

4. Type the component class in the Component Class box. 

5. Type 175 F in the Temperature Rating box. 

6. Type 205 PSI in the Pressure Rating box. 
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7. Click the Size Table list, and then select Size. 

8. Deselect 8.0000, 16.0000, and 28.0000 (200,400,700) sizes using the Available Size list. 

9. Click the Thickness Table list, and then select THCK. 

10. Click the Thickness Table ellipsis.  

The Schedule Assignment dialog box that displays.  

11. Click the box to the right of 2.5000 (65), and then select 10S. 

12. Click the box to the right of 5.0000 (125), and then select XS. 

13. Click the box to the right of 6.0000 (150), and then select XXS. 

14. Click the box to the right of 14.0000 (350), and then select STD. 

15. Click OK when finished. 

16. Click the Material Table list, and then select MAT. 

17. Click the Layer Color list to select Blue. 

18. Type your name in the Created By box. 

19. Type Ezz Piping's 150 Blue Spec the Description box. 

20. Click OK. 

The new spec is added under the project name in Project Data. 

We now need to Add a component to the spec (on page 62). 
 

Add a component to the spec 

1. Double click the spec in the Project Data pane. 

The spec displays in the main window with the New Component dialog box visible. 

 Some of the information in this screen defaults to the settings from when the spec was 
initially set up. 

2. Click the Group list, and then select Caps. 

3. Click the Type list, and then select Plug. 

4. Click the Data Table list, and then select PLG_T_30C. 

5. Click the Sizes type list, and then select 5.0000 (125), and 6.0000 (150). 

6. Type PL-0511 in Tag.  

7. Type Blue Plug for Ezz Piping in Notes information as needed in their respective boxes. 

8. Click Add at the top-right hand side of the New Component pane. 

The component is added to the list in the main window. 

Now that we have added a single component we can Add the remaining components to the spec 
(on page 63). 
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Add the remaining components to the spec 

1. Double-click the spec in the Project Data pane. 

The spec displays in the main window with the New Component dialog box visible. 

2. Right-click the component listing area of the screen, and then select Add Multiple. 

The Add multi component dialog box displays. 

 Some of the information in this screen defaults to the settings from when the spec was 
initially set up. 

3. In the Component box, select all the check boxes except Sanitary and Spec Blind/Bleed 
Ring/Exp Joint. 

4. Click the plus + sign on Caps, and click the check-box for Plug to clear it.   

5. Click Apply same end-type on all ends. 

6. Click the Start list, and then select BW. 

7. Click the Main Schedule list, and then select STD. 

8. Click the Branch Schedule list, and then select STD. 

9. Type EZZ-Comps in Tag.  

10. Type Ezz Piping does not allow for the use of Spec Blind/Bleed Rings/Exp Joints as 
well as Sanitary Components. All Ezz Piping's End Types are Buttweld. in Notes. 

11. Click Add at the top-right hand side of the Add Multi Component pane. 

The components are added to the list in the main window. 

 When setting the available component size range, make sure that it corresponds with 
the size ranges available for each selected data table. 

Now we must Define the data tables and branches for the components (on page 63). 
 

Define the data tables and branches for the components 

1. Click the plus + sign next to Caps, and then select the first red exclamation point. 

The line is highlighted. 

2. Click the Data Tables list in Edit Component dialog box, and then select a data table. 

3. Click Apply. 

4. Repeat this procedure for the remaining red exclamation points. 

Now we must set the branch table per Ezz Piping's request. Ezz Piping uses Reducing Tee / 
Cross for all sizes. They use O-Let, and Half Coupling for anything under 12" (300mm), and they 
use  Stub-In / Set-On / OTAP for 6" (150mm), and below. For components with the same sizes 
both options available can be used. 

1. Click the Branch tab at the bottom of the Add Multi Component pane. 

A grid displays with Branch Size (NPS), and Main Size (NPS) on the top, and side. 

2. Right-click the box at the intersection of 64 (1600), and 0.125 (3), and then add Reducing 
Tee /Cross.   

The grid box changes displaying that you have added a component. 

3. Continue to adjust the table as needed with the information from above. SHIFT+click and 
CTRL+click can be used to select multiple intersections at a time. 

4. Click File > Save when finished. Every time a change is made it must be saved to take affect. 
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Edit an existing project 
In this lesson, we are updating a predefined product to match the Catalog we edited for DJ Piping. 
This way we now have a project and a catalog for DJ Piping based off of the original specifications.  

1. Click File > Open . 

2. Click Sample_Inch.prj, and click Open. 

Click File > Save As . 

 If you do not save changes to a different file, then you are making changes to a 
delivered specification. If you save these changes directly to Sample_Inch.prj you may have 
to re-install CADWorx to return your setup to default. It is highly recommended that you save 
this using another name before continuing. 

3. Type Inch Example Tutorial, and click Save. You can choose to save this outside of the 
Spec Folder in a folder on your computer. 

If you want to practice adding new specs to an existing project use the steps in Create a New 
Project (on page 61). The following tutorial demonstrates how to edit the 150 Spec, and the 600 
Spec. We also edit the properties for some of the options. 

1. Select 150 under Sample Inch in Project Explorer.  

The table displays to the right of the Project Explorer.  

2. Hold CTRL and select the Spec Blind/Bleed Ring/Exp Joint and O-Lets.  

3. Right click and then click Remove. 

The Remove dialog box displays. 

4. Click OK. 

The Spec Blind/Bleed Ring/Exp Joint and O-Lets groups are removed. 

5. Right-click 150, and select Properties. Alternatively, click the View tab, and then select 
Properties in the Display panel. 

The Properties window opens. 

6. Click the number 150 next to Specification Name, and then delete it. 

7. Type DJ Piping 150 Specs, and then click anywhere in the screen. 

The Specification Name changes. 

8. Click the Color list, and select Green. 

The Apply to all components dialog box displays. 

9. Click Yes. 

10. Click the Default Flange list, and then select Flange Weld Neck. 

11. Type your name in the Edited By box. 

12. Type DJ Piping Requested Spec Changes in the Description box. 

Now we are going to edit the 600 Spec. 

1. Select 600 under Sample Inch in Project Explorer.  

The table displays to the right of the Project Explorer.  

2. Hold CTRL and then select the Spec Blind/Bleed Ring/Exp Joint, Couplings, Caps, 
Unions, and O-Lets.  

3. Right-click and then click Remove. 

The Remove dialog box displays. 
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4. Click OK. 

The Spec Blind/Bleed Ring/Exp Joint, Couplings, Caps, Unions, and O-Lets groups are 
removed. 

5. Right-click 600, and select Properties. Alternatively, click the View tab, and then select 
Properties in the Display panel. 

The Properties window opens. 

6. Click the number 600 next to Specification Name, and then delete it. 

7. Type DJ Piping 600 Specs, and, then click anywhere in the screen. 

The Specification Name changes. 

8. Click the Color list, and then select Cyan. 

The Apply to all components dialog box displays. 

9. Click Yes. 

10. Click the Default Flange list, and then select Flange Weld Neck. 

11. Type your name in the Edited By box. 

12. Type DJ Piping Requested Spec Changes in the Description box. 

13. Click File > Save. 

Now change the 300 Spec per the following DJ Piping information 

 300 spec does not use Caps, Unions, and O-Lets. 

 300 is requested by DJ Piping. 

 300 uses a red color for its components. 

 300 has a Flange Weld Neck as its default. 

 300 description is DJ Piping Requested Spec Changes. 
 

Optional components 
To make a component an optional component do the following. 

1. Open the Spec Editor . 

2. Open the Inch Example Tutorial project. 

3. Click the 150 spec, and then select a component. 

The Edit Component dialog box opens. 

4. Click the Optional Component check-box, and then click Apply. 
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 As long as the Specification Option Toggle is on, a dialog box similar to the example below 
opens when you place 300# orifice flanges.   

 

 Specification Option Toggle also provides the ability to place a schedule 80 8" (200mm) 
pipe schedule STD is the 8'' default. Thus, making the 8” (200mm) pipe schedule 80.   

 There are many other useful functions within the Specification Editor that are not discussed in 
this lesson. For more information about all of the available functions, see the Specification 
Editor in the CADWorx Plant User's Guide or any topic in the CADWorx Spec Editor Users 
Guide  

 

User Shapes 
In this lesson, we create a typical user shape and add it to a specification. CADWorx automatically 
creates all the data files and blocks that are required. You can use the Tutor12.dwg 
(Tutor12m.dwg) file delivered with the software, or create the drawing shown below using the 
following guidelines.  

 Use the ROUTE command to draw the main body of the swept tee.  

 Use the Adjustable Bend command on the Buttweld tool bar to draw the swept part. Draw 
both parts at 4" (100mm), and then use the AutoCAD UNION command to join them together.  

 Use Pipe  command (PIPW) to draw the hubs with the size set to 6" (150mm).  

 Make sure PICKSTYLE is turned off, and the centerlines are erased.   

 

 The size of this component is 4" (100mm). It is a typical PVC swept tee for plumbing 
purposes.   
 



 CADWorx Plant Tutorial 

 

 

CADWorx Plant Tutorial 67 
 

Create the component 

1. Click Create . Alternatively, type USERCREATE on the command line, and press ENTER. 

The Define User Shape dialog box displays. 

2. Type SWEPT TEE in the Name box. 

3. Select user shape number 1 in the Number list.   

4. Select 150 in the Specification list. 

5. Assign the user shape to 300 using the Assign to Spec list. 

6. Click the Save to catalog check box.  

 This is the default setting. 

7. Select Block from the Type list. 

8. Select 4 (100mm) in the Main Size list. 

9. Click Select 3D Solid. 

Select 3D solid representation. 

10. Click a point in the upper left of the drawing, drag the mouse, and then click in the lower right 
of the drawing to select the entire user shape. Press ENTER to finish the selection. 

Pick insert point. 

11. Select the lower right part of the swept tee for the insertion point on the component. 

12. Click Define Connections. 

Pick direction. 

13. Select the opposite direction away from the component.  

Set End Type for this connection: [Buttweld/Socket/Threaded/Flanges]<Butt weld End Type>. 

14. Press ENTER to select the default. 

Pick connection 1 or <Enter to finish>.  

15. Pick the point at the upper left connection of the main run of the same component. 

Pick direction. 

16. Select the opposite direction away from the component.  

Set End Type for this connection: [Buttweld/Socket/Threaded/Flanges]<Butt weld End Type>. 

17. Press ENTER to select the default. 

Pick connection 2 or <Enter to finish>. 

18. Pick the point at the branch connection of the component. 

Pick direction. 

19. Select the opposite direction away from the component.  

Set End Type for this connection: [Buttweld/Socket/Threaded/Flanges]<Butt weld End Type>. 

20. Press ENTER to select the default. 

Pick connection 3 or <Enter to finish>. 

21. Press ENTER to finish. 

The Define User Shape dialog box displays. 

 Connection points indicate where other equipment or components attach to the 
nonsymmetrical user shape. These points are very important when exporting the model to an 
automatic isometric and affect the scaling if not properly selected. 

22. Select Misc in the BOM Type list. 
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23. Select White in the Color list. 

24. The layer should display as 150 in the Layer box. 

25. Type 0.2838 (7.8417) in the Density box. 

26. Type 15 (6.8) in the Weight box. 

27. Type 1'-11.8125 (605) in the Length box. 

28. Select Optional Component. 

29. Type Swept Tee in the Long box. The long description is used within the data file. 

30. Type SWTEE in the Short box. 

31. Type SWT-001 in the Tag box. 

 The software automatically defines the next five options.  

32. Click OK. 

The software creates the user shape, and adds it to the specification. 

 If the reducing option had been used, the two blocks would have names such as 
SWEPTTEE[4.0x3.0-2D].dwg.   

 

Draw the component 
For any user shape, there are two options that insert it into the drawing. You can use the User 1 
through User 5 commands on the Misc toolbar or you can select the user shape in the Spec View 
palette under User Shapes. 

1. Click Main Size . Alternatively, type SETSPEC, or SETSIZE on the command line, and 
then press ENTER. 

The Set Specification and Size dialog box appears. 

2. If a project is already selected skip to step 3. If the Project box is empty, click Browse, select 
Sample_Inch.prj, and then click Open. 

3. Select 150 under Specifications, and 4 (100) under M for main size. 

 If you are working in Metric units, open the 150MM specification file. 

4. Click and hold Create  on the Misc toolbar, and then select User 1  on the fly-out menu. 

Pick point or [Change connection]<last point>. 

5. Pick a point in the drawing. 

 The next set of prompts allow you to rotate the component, mirror it in the X-, Y-, or 
Z-axis, and roll it up, down, or at any angle of your choosing. As such, the component can be 
placed in the drawing in virtually any position. 

Pick rotation or [Up/Down/Roll/mirrorX/mirrorY/mirrorZ]. 

6. Type X on the command line, and press ENTER to select the mirrorX option. 

Pick rotation or [Up/Down/Roll/mirrorX/mirrorY/mirrorZ]. 

7. Pick a rotation. 

The user shape is placed in the drawing. 

 
 

Change the size of a model 
The following tutorial demonstrates how to change the size of a model. Draw a pipe run with three 
connections. Each connection end has a reducer and a flange. One of the connections should 
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extend from the middle of the pipe using a tee. The Specification for the drawing is 150, the main 
size is 4" (100), and the reducing size is 3" (80).      

1. Use the ROUTE command to draw a pipe run similar to the one below. 

 

2. Click the CADWorx Plant I tab, and then click Change Size  on the Setup Size/Spec 
panel. Alternatively, type CHANGESIZE on the command line, and then press ENTER. 

Select mode[Automatic/Manual]<Automatic>. 

3. Press ENTER for automatic. 

Select line to change.  

4. Select the line to the right of the tee. 

The size list displays. 

5. Select 2" (50). 

Select branches to change size or <Enter to finish>. 

6. Select the bottom tee, and then press ENTER to finish. 

Enter an option [Change component/Reducing/None]. 

7. Type C on the command line, and then press ENTER. 

8. Repeat step 7 for the other two reducers. 

Select a component to keep its position or [Enter to finish]. 

9. Press ENTER to finish.  

The drawing changes size. 
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Change the specification of a model 
The following tutorial demonstrates how to change the spec of a model we create. Draw a pipe run 
with three connections. Each connection end has a reducer and a flange. One of the connections 
should extend from the middle of the pipe using a tee. The Specification for the drawing is 150, the 
main size is 4" (100), and the reducing size is 3" (80). 

1. Use the ROUTE command to draw a pipe run similar to the one below. 

 

2. Click the CADWorx Plant I tab, and then click Change Spec  on the Setup Size/Spec 
panel. Alternatively, type CHANGESPEC on the command line, and then press ENTER. 

Select mode[Automatic/Manual]<Automatic>. 

3. Press ENTER for automatic. 

Select line to change.  

4. Select the line above the tee. 

The spec box displays. 

5. Select 300. 

Select a component to keep its position or <Enter to finish>. 

6. Press ENTER to finish. 

The line above the tee changes colors indicating the spec has changed. 

Having changed the relief line to 300 we are now going to change the main line to 600 

1. Type CHANGESPEC on the command line, and press ENTER. 
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Select mode[Automatic/Manual]<Automatic>. 

2. Type M for manual. 

Select components.  

3. Select all the components on the main line, and then press ENTER when finished. 

The spec box displays. 

4. Select 600. 

Select a component to keep its position or <Enter to finish>. 

5. Press ENTER to finish. 

The spec changes on the main line. 

Change the spec of a model with branches using Automatic 

1. Click the CADWorx Plant I tab, and then click Change Spec  on the Setup Size/Spec 
panel. Alternatively, type CHANGESPEC on the command line, and then press ENTER. 

Select mode[Automatic/Manual]<Automatic>. 

2. Press ENTER for automatic. 

Select a piping line.  

3. Select a pipe line. 

The spec box displays. 

4. Select a specification. 

Select branches to change spec or <Enter to finish>. 

 If you decide not to select the branches in step 5, the spec still changes on the 
branching components but does not change on the branches themselves. 

5. Select the branches. 

Select a component to keep its position or <Enter to finish>. 

6. Select a component or press ENTER to finish. 

 If you selected a component you are prompted again, and need to repeat step 5. 

The selected system changes specification up to any reducer locations. 
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